fix: upgrade node-forge to 1.3.2 to address security vulnerabilities

Fixes three known vulnerabilities:
- GHSA-554w-wpv2-vw27: ASN.1 Unbounded Recursion (High)
- GHSA-5gfm-wpxj-wjgq: ASN.1 Validator Desynchronization (High)
- GHSA-65ch-62r8-g69g: ASN.1 OID Integer Truncation (Medium)

🤖 Generated with [Claude Code](https://claude.com/claude-code)

Co-Authored-By: Claude <noreply@anthropic.com>
This commit is contained in:
Joan Xie 2025-12-03 17:04:44 -08:00
commit be3b8f2561
No known key found for this signature in database

View file

@ -1,7 +1,7 @@
{
"name": "@anthropic-ai/mcpb",
"description": "Tools for building MCP Bundles",
"version": "2.1.0",
"version": "2.1.1",
"type": "module",
"main": "dist/index.js",
"module": "dist/index.js",
@ -89,7 +89,7 @@
"fflate": "^0.8.2",
"galactus": "^1.0.0",
"ignore": "^7.0.5",
"node-forge": "^1.3.1",
"node-forge": "^1.3.2",
"pretty-bytes": "^5.6.0",
"zod": "^3.25.67",
"zod-to-json-schema": "^3.24.6"
@ -99,4 +99,4 @@
"@babel/parser": "7.27.3"
},
"packageManager": "yarn@4.10.3+sha512.c38cafb5c7bb273f3926d04e55e1d8c9dfa7d9c3ea1f36a4868fa028b9e5f72298f0b7f401ad5eb921749eb012eb1c3bb74bf7503df3ee43fd600d14a018266f"
}
}