fix: upgrade node-forge to 1.3.2 to address security vulnerabilities
Fixes three known vulnerabilities: - GHSA-554w-wpv2-vw27: ASN.1 Unbounded Recursion (High) - GHSA-5gfm-wpxj-wjgq: ASN.1 Validator Desynchronization (High) - GHSA-65ch-62r8-g69g: ASN.1 OID Integer Truncation (Medium) 🤖 Generated with [Claude Code](https://claude.com/claude-code) Co-Authored-By: Claude <noreply@anthropic.com>
This commit is contained in:
parent
9c22416146
commit
be3b8f2561
1 changed files with 8 additions and 8 deletions
10
yarn.lock
10
yarn.lock
|
|
@ -36,7 +36,7 @@ __metadata:
|
|||
galactus: "npm:^1.0.0"
|
||||
ignore: "npm:^7.0.5"
|
||||
jest: "npm:^29.7.0"
|
||||
node-forge: "npm:^1.3.1"
|
||||
node-forge: "npm:^1.3.2"
|
||||
prettier: "npm:^3.3.3"
|
||||
pretty-bytes: "npm:^5.6.0"
|
||||
ts-jest: "npm:^29.3.2"
|
||||
|
|
@ -4739,10 +4739,10 @@ __metadata:
|
|||
languageName: node
|
||||
linkType: hard
|
||||
|
||||
"node-forge@npm:^1.3.1":
|
||||
version: 1.3.1
|
||||
resolution: "node-forge@npm:1.3.1"
|
||||
checksum: 10c0/e882819b251a4321f9fc1d67c85d1501d3004b4ee889af822fd07f64de3d1a8e272ff00b689570af0465d65d6bf5074df9c76e900e0aff23e60b847f2a46fbe8
|
||||
"node-forge@npm:^1.3.2":
|
||||
version: 1.3.3
|
||||
resolution: "node-forge@npm:1.3.3"
|
||||
checksum: 10c0/9c6f53b0ebb34865872cf62a35b0aef8fb337e2efc766626c2e3a0040f4c02933bf29a62ba999eb44a2aca73bd512c4eda22705a47b94654b9fb8ed53db9a1db
|
||||
languageName: node
|
||||
linkType: hard
|
||||
|
||||
|
|
|
|||
Loading…
Reference in a new issue